Skip to content

Enabling Photoscenery?

edited November 2023 in General FlightGear chat

Hi all,

I tried to update my install pf FGFS today using the scripted download and compile method. I think this failed as FGFS says I'm still on a 2020 version.

I had a quick go at EGOD with photoscenery box checked, but no photoscenry. Are only parts of the world available? Do I need to manually install photoscenery?

Does 2020 support photoscenery?

I need to figure out my FGFS update, over the coming days will try again.

Cheers, Scott


  • you need to supply your own for FG to use it.

  • Bugger, another challenge!


  • It's nice and easy to install it though, as kindly detailed by Stuart in his usual informative way ????

    Those folders there for the England and Scotland areas can just be added like any normal scenery in the structure [Folder name]>Orthophotos>Location

    As an example I've got mine all in one folder here:


    I have


    Added as a scenery folder in the launcher's "add-ons" area and it then picks up that there's an Orthophotos folder in it. You can either bung all the photoscenery you get in one orthophotos folder like me, or you can add them individually so you can remove it as you wish.

    Perhaps like X:\FlightNightScenery\Orthophotos\e000n51

    Both work, the key is having the Orthophotos folder inside the folder you add as a scenery folder and that should work fine.

    Let us know if you get any issues with it.


  • I created the  Orthophotos folder inside my terrasync directory. That way, its automatically detected along with its contents when when you tick the box in your FG rendering options.

  • Thank you both for the files and advice on methods of installing.

    Who do we ooew thanks to for putting the tiles together? And what license are they?

    Cheers, Scott

  • There not GPL.

  • edited November 2023

    I think the England Zip file may be corrupt, I can't unzip it. (Not tried Scotland yet):

    $ unzip


    warning []: 1774699037 extra bytes at beginning or within zipfile

     (attempting to process anyway)

    error []: start of central directory not found;

     zipfile corrupt.

     (please check that you have transferred or created the zipfile in the

     appropriate BINARY mode and that you have compiled UnZip properly)

    I have downloaded England a couple of times, tried turning off my VPN, tried a couple of different ways to unzip it too... no joy. Trying Scotland now.

  • It works. Its the one we issue ever Englandshire flight night

  • Scotland was a success, Just flew around the (familiar to me) Dyce/Aberdeen and the golf course at Ardoe. Looks brillliant given a touch of altitude!

    I'll try England again..


  • edited November 2023

    I'm definitely having issues with the England zip file. Just tried a fresh download, no VPN, wired Ethernet network, tried two different unzip methods, and am getting the exact same issue as before:

    $ unzip


    warning []: 1774699037 extra bytes at beginning or within zipfile

     (attempting to process anyway)

    error []: start of central directory not found;

     zipfile corrupt.

     (please check that you have transferred or created the zipfile in the

     appropriate BINARY mode and that you have compiled UnZip properly)

    I know it's a big download, but could someone else please try the England zip file? It's either corrupt, or is being corrupted during the download process.

    Thanks, Scott

  • I tried it a long time ago when Stuart released it and had the same issue.

    No England for me I figured and never brought up the issue.

  • Thanks Timi, not just me then!

  • How strange!

    I'm out this evening but if nobody else gets chance to look I'll have a poke about later this eve or tomorrow morning

  • Had the same issue using unzip. I tried another programm: and it worked!

  • I just downloaded it and it unzipped fine with 7 Zip


  • Thank Voodoo, I just gave that a go, had one error reported, but a lot of folders and files did get extracted.. However, FGFS isn't using them even though I have set the path up and enabled it.

    Extract info:

    $ 7z x

    7-Zip [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21

    p7zip Version 16.02 (locale=en_GB.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs Intel(R) Core(TM) i5-4300U CPU @ 1.90GHz (40651),ASM,AES-NI)

    Scanning the drive for archives:

    1 file, 6069744859 bytes (5789 MiB)

    Extracting archive:


    Headers Error


    Path =

    Type = zip


    Headers Error

    Physical Size = 6069744859

    64-bit = +


    Archives with Errors: 1

    Open Errors: 1

  • Currently, I have the following folder structures with these files:



    Scotland works fine, but England does not, I have tried London, Bristol, Birmingham, Manchester, no joy.

    Launcher Add-Ons is set correctly:

    In England I tried disabling and re-enabling from within FGFS, still no change.

    It leads me to think there may be some corruption in the England files, since it was a struggle to unzip, even when 7z unzipped it, an error was still reported (previous post).

  • edited November 2023

    It's the same files a dozen of us have fine here. I'm clueless. Seems like maybe your computer is choking during unzipping.


  • edited November 2023

    Just a thought, as it's a rather large zip file, over 6 GB - I only have just less then 4GB of RAM, and just less than 2 GB of swap memory, totalling less then the size of the zip file, maybe this issue could be down to a limitation of my machine? Just thinking the Scotland zip file was smaller so may not have been such an issue for my machine.

    I guess most people here have gaming computers with lots of RAM, which may explain why it's not been an issue? I'me just trying to get it working on a temperamental old laptop.

  • Just to try unzipping it on another machine, I've just checked my PC, same amount of RAM and even less swap. The PC was my grandmothers, I inherited it when she passed away about 8 years ago...

    I've just found a way to use my server (plenty of RAM) at the command line to download the zip from google drive using wget, I'll try this to acquire and unzip the files, then transfer them over.

  • edited November 2023

    Haha, downloading using wget at the command line using from Google Drive is a bit tedious to get round Googles cookie nonsense:

    England wget command:

    wget --load-cookies /tmp/cookies.txt "$(wget --quiet --save-cookies /tmp/cookies.txt --keep-session-cookies --no-check-certificate '' -O- | sed -rn 's/.*confirm=([0-9A-Za-z_]+).*/\1\n/p')&id=1aDsv7_xsu6Rq3Nkuwq0LJr2T0hg2UpFI" -O && rm -rf /tmp/cookies.txt

    Scotland wget command:

    wget --load-cookies /tmp/cookies.txt "$(wget --quiet --save-cookies /tmp/cookies.txt --keep-session-cookies --no-check-certificate '' -O- | sed -rn 's/.*confirm=([0-9A-Za-z_]+).*/\1\n/p')&id=1ZU04s_qKCAjRtMaIIaFyobIeSxyEOcu9" -O && rm -rf /tmp/cookies.txt

    Guidance source:

  • edited December 2023

    Hmmm... So, after downloading it to my server with the above wget command, I then used 7z to unzip it, but found the same error!

    So, regarding the RAM theory, my server has 32GB of RAM, stil threw the same error as the laptop with a poxy amount of RAM.

    I will copy these extracted files across to my laptop later to see if England scenery loads though.

  • Ok, so extracting on the server still found an error in the zip file, but I copied the extracted files across to my laptop, gave Bristol a try, and was pleasantly surprised! It worked! So it may have been something to do with limited RAM size on my laptop after all?

  • No clue, Scott. It's all just magic to me anyway.


Sign In or Register to comment.